Archive

Posts Tagged ‘Studio 2’

Update: Olympus Studio 2 for Mac & Time Lapse Photography

January 3rd, 2012 No comments

As an Olympus and Mac user, I have Olympus Studio 2 (version 2.3) to allow me to tether my E-system camera and control it from my MacBook. In 2010, I posted about my experience with tethering an Olympus E-501 with a Mac using Studio 2. This is an update on my experience since that post.

I have since stopped tethering whenever possible, mainly because I do not like the restriction of being attached by the USB cable during a shoot. There are also a few other reasons for not tethering. I had an incident with my E-510 when it was tethered. I stepped on the cable when it was attached to the camera and the force bent the pins of the camera’s USB socket, rendering it unusable. The same socket is also used for downloading images from the camera, and for operation of the remote control. I could have it repaired, although the expense is probably not worth it because the E-510 is an older camera body.

I now own an E-30, which also has a similar USB socket and must use Olympus Studio 2 for the Mac for tethering. I don’t want to risk damaging the body, so will only tether using something like the JerkStopper or other device to protect the camera.

Another problem that I encountered with Olympus Studio 2 was software crashes. During nearly every shoot, at least once Olympus Studio 2 would freeze and only work again after rebooting my Mac. As a Mac user I rarely encounter this situation — normally it’s easy to force quit and restart the application without rebooting. Rebooting and initializing everything takes some time, and is not good during a studio shoot with clients and models on set! I generally take a break to sort it out, but it does waste valuable studio and talent time, and stops the flow of the shoot.

Olympus Studio 2 has a great time lapse feature, however, I recently discovered that time lapse does not work with Mac OS 10.6 (Snow Leopard) or OS 10.7 (Lion). It does work with 10.5 (Leopard). I checked with Olympus customer support, and they responded:

Unfortunately the Time Lapse function in the Mac version of Olympus Studio 2.3 no longer functions. This occurred after an APPLE OS update awhile back. But because Studio is officially discontinued there is no patch to address this.

Time lapse is not built into my camera, but I can do time lapses with an intervalometer, or using a clever hack with an eraser and rubber band!

There is a big need for better tethering support for Olympus E-System cameras for Mac users. According to the forums that I’ve read, it would require Olympus to licence the software development kit (SDK) to third-party developers which they have done for Windows but not for Mac. That could allow the Olympus camera tethering with other applications such as Lightroom or Capture One. But at this time that does not seem to be likely.

UA-12397519-1